更新ibus和ibus-pinyin的ports到1.4.0

其实早就该更新的…… 不过之前尝试了一下,觉得1.4.0不咋的,还有些问题,于是没管……
结果终于有好心人搞了个1.4.0的patch,还群发邮件说各位基于ibus的ports的maintainer们,快更新吧!
他顺便还加上了GTK3支持的选项,看来大家都要渐渐向GTK3迁移了么……

在那个patch的基础上,提了些修改,现在在等待commit……
具体来说:
* 貌似其实ibus不依赖Qt?为啥从前加上去了呢…… 于是去掉了
* 没有post-deinstall这个target的,应该在pkg-plist里用@unexec来执行卸载命令的……
所以从前的ibus port删除之后,是不会更新gtk2的immodules列表的…… 这么多时间了也没人发现……

为了这个,ibus-pinyin也更新到1.4.0。但是ibus-pinyin 1.4.0居然要编译器支持c++0x…… BSD的古老的gcc 4.2怎么行……
于是就让port依赖gcc 4.4+,没办法…… 其实ibus-pinyin还有个替代选项是用boost,但是开了之后没法编译。虽说打个补丁应该可以,但是太麻烦…… 另一个好处是,现在就不依赖boost了……
其他更改:
* 不知道为啥,ibus-pinyin有个${DBTAR}在DISTFILES里,而这个东西没定义过…… 删了删了
* 去掉boost支持,反正依赖gcc 4.4+了……
* RUN_DEPENDS单独定义。这个是portlint说的,说BUILD_DEPENDS其实还有别的东西,不能直接赋给RUN_DEPENDS
* 目前禁用lua扩展。反正也没人用……
* 加了俩选项,选择是否编译Android DB和OpenPhrase DB。貌似是俩词库,OpenPhrase 那个挺大……
* 加了选项是否依赖opencc进行简繁转换

ibus 1.4.0在gvim里有些问题,换篇文讲吧……

于是就等待commit了~